HayesJupe's Blog

September 29, 2010

Exchange 2010 – OWA

Filed under: Exchange — hayesjupe @ 6:56 am

99% of the time i use RPC/HTTP (or Outlook anywhere) to access my mail externally, but the other day i was forced to use OWA for the first time since i updated to Exchange 2010 SP1.

What a pleasant surprise. OWA has been given a minor, yet nice graphical overhaul that makes it look about 10 million times better. The annoying coversation based view is still the default, but the conversations actually expand in a reasonable time now instead of taking 10 seconds to open – and the layout is nicer and easier to navigate.

SP1 was always going to be full of good stuff – but this one was a bit unexpected by me – good stuff exchange team.

Advertisements

2 Comments »

  1. For us it looks worse than OWA ever looked. And everybody tries to tell me that this is the correct ‘default’ view of Microsoft Exchange 2010 SP1 OWA.
    See for yourself:
    https://skydrive.live.com/embedalbum.aspx/OWA2010SP1?cid=6dcd492ec389dd92&sc=photos
    (https://skydrive.live.com/embedalbum.aspx/OWA2010SP1?cid=6dcd492ec389dd92&sc=photos)

    Comment by florisz — July 4, 2011 @ 5:35 pm | Reply

    • well – i spose everyone has different taste…. if you dont like it then either ask MS for a new theme via your TAM (good luck with that) or create your own theme.

      Comment by hayesjupe — July 8, 2011 @ 6:41 am | Reply


RSS feed for comments on this post. TrackBack URI

Leave a Reply

Please log in using one of these methods to post your comment:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

Blog at WordPress.com.

%d bloggers like this: